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3D Beam Modeling Tutroial 

A Cantilever Block Beam Tutorial  
 

In this tutorial, we will carry out the complete cycle of a simple FEA analysis for a simple 
cantilever beam: 
1) Model Creation in AMPSolid 
2) Element and node generation using AMPSolid 
3) Model physics definition in AMPView 
4) Analysis using AMPSol 
5) Post-processing in AMPView. 
 
We have also included a completed solved model called "bksolved" in the AMPS installation 
subdirectory "Tutorial" in case you want to skip the model definition portion and jump into the 
finite element solver and processing sessions, or just want to see the result of this tutorial. The 
corresponding solid model is also available in the file "block1tut.sat". 
 
We suggest that you arrange your Windows screen properly so you can see this tutorial 
Windows and the AMPS programs so you see both windows properly. 
Create a Solid Beam Model 

 

The example solid model that we are creating is a simple block of size 2x2x4.  This is the 
simplest solid model that we can create in a few minutes.  
 
1. Select the AMPSolid icon (or select AMPSolid in AMPS program file group) to start the 

AMPSolid program. After the initial startup, select File>New menu to start a new session 
(File>New means to select the New option from the File menu. Operations that need to be 
performed to complete the tutorial are in Bold). 

2. To set up a proper view for this block construction, select View>Camera Control (From 
the View menu select the Camera Control option), and set the screen ViewPort width to 
10 (so we can see the 2x2x4 block during the construction) and click OK. Typically if the 
model is in units from -25 to 25 we can start with the default size and then enclose the 
model with the Zoom All command. Zoom all is the left icon on the Zoom 

toolbar:   
3.  Click on the isotropic view icon to set an isotropic view. The isotropic view icon has ZY 

and X on it. It is leftmost icon in the AMPSolid preset camera view toolbar. 

 
4. Select Create>Block (from the Create menu select the Block option). You can press the 

F1 key when the cursor is over the Block option in the Create menu to access AMPSolid's 
help about block construction). At this moment, the program is waiting for you to enter 3 
corners to define a block. We will use the SCC box to precisely enter the coordinates. The 
orientation of the block is based on the current WCS (Working Coordinate system). The 
initial WCS matches the Global Coordinate System (origin at (0,0,0) and X, Y and Z axes 
oriented normally) so we don't need to change the WCS. 

5. We are making a block that will be 4 units in the X direction, 2 units in the Y direction and 2 
units in the Z direction. We will enter the coordinates in the SCC (Status and Cursor 
Control) box on the lower right portion of the screen. If this dialog box is not visible, make 
sure the Options>SCC box menu item is checked. In the SCC dialog, Click the [Reset] 
button to force all the Position coordinates to be zero. Then click the [Enter Pos] button to 
enter the current position as one of the model points for the block. 
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6. You can move the mouse onto the screen to verify that you have entered a point at the 

global origin (0, 0, 0). The global origin is displayed on the screen as three small axes lines 
that match the axes color of the orientation axis at the bottom right of the screen. 

7. If you hold the control key down while moving the mouse, a snap cursor appears and the 
global coordinate position on the bottom right of the screen displays the snap location in 
global coordinates. If you hold down the shift along with the control key, the current snap 
position is also copied into the position value of the SCC box when the mouse is moved. 

8. We'll use the keyboard to enter the other points of the block. To enter (4, 2, 0), Double 
click on the X position field in the SCC box to select it (it is located just to the right of 
the [Enter Pos] button. Now enter 4 <Tab> 2 <Tab> 0 <Tab> <Enter>. Where <Tab> 
means press the tab key and <Enter> means press the Enter key. 

9. Clicking on the [Enter Pos] button or pressing <Enter> when the words Enter Pos have a 
dashed line around them, enters the point into the model and selects the X Position field 
so that another coordinate can be entered. To enter (4, 2, 2) as the final point, enter 
<Tab><Tab>2<Tab><Enter> (or double click on the Z position field, enter 2 and click on 
the [Enter Pos] button). 

10. Click on the Zoom All button  to enclose the model. The screen should look like this: 

 
 
If the screen does not look like this, you can use Edit>Undo to undo the block creation and 
repeat steps 4 through 10 to enter the block again. If the prompt is "Click the left button for 
a corner point of the base rectangle", you the Create>Block tool is still active and you can 
skip step 4. 
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11. The message at the bottom left of the screen indicates that AMPSolid is now waiting for 
you to create another block. Mouse operations that change the view, the WCS or measure 
distances are called toggle commands because they can be toggled on and off without 

affecting the current construction operation. To try this, click the dynamic rotate icon  
and move the cursor over the model window. The cursor changes to the dynamic rotate 
cursor and you can drag the mouse while holding down the left mouse button to rotate the 
view. After rotating the view, click on the dynamic rotate icon again to turn off dynamic 
rotation. The status line prompt change back to the block construction prompt to allow you 
to continue with block construction. This works even after you have entered some of the 
construction points. 

12. To exit block construction mode, select Create>Abort Geometry Tool or click on one of 

the first 4 icons from the Selection toolbar:  . The selection tools 
are not toggle commands so they abort the current geometry construction. Construction 
commands can be aborted even after points have been entered. 

We have now created a simple solid model that can be used for finite element analysis. It is 
recommended that you save this model by selecting File>SaveAs and entering block1 as the 
file name (this saves the file as block1.sat). This solid block model is also available in the 
AMPS installation subdirectory "Tutorial", in file block1tut.sat, in case you want a pre-
constructed solid block model. 
Create the Mesh Using AMPSolid 
 

In this section you will create a tetrahedral mesh for the 4x2x2 block that you created and 
saved in the block1.sat file. To create the volume mesh, you will first create a triangular 
surface mesh and then generate a tetrahedral volume mesh from the surface mesh. 
 
If you are continuing from the previous section, skip to step 3. Otherwise, perform step 1 and 2 
to start the AMPSolid program and retrieve the solid block model from the file 
 
1. Select the AMPSolid icon from the AMPS folder group (or select AMPSolid in AMPS program file 

group) 
2. Input the model by selecting File and select block1.sat from the recently used list. If you 

haven't created a block1.sat, select block1tut.sat from the Tutorial sub-directory and open 
it. Then use File>Save As and save it as block1.sat to match the tutorial file name. 

3. We will generate a tetrahedral volume mesh for the block. The first step is to mesh the 
surface of the block with a triangular mesh (a Tri Face mesh). Here is the detailed steps 

• Click on  to select body selection and then click on the block. The block color 
should change to red to indicate it is selected.  

• Select selecting AutoMesh>Pre-Solid Tri Face Creation …. 
• In the dialog box, Set the Approximate Size of Side to 0.5, and click OK to generate 

the surface triangle mesh. 
4. The second step is to fill the interior with a solid tetrahedron mesh. Select 

AutoMesh>Tetra (Solid) from Tri Faces. You should see a message that the tetra mesh 
cells have been generated and ready for export to the mesh server. Click OK. 

5. Examine the resulting mesh by using the dynamic rotate command: . 
6. Export the mesh by selecting File>Export Mesh, and then click OK to accept the default 

options of the Cell Mesh Export Control dialog. Enter block1 as the filename (block1.fe 
should be the default, any extension will be ignored) and click Save. You should see a 
Finished transfer … message. Click OK to close the message. AMPSolid just generates 
three files. Block1.fe contains the finite element mesh data. Block1.dat and block1.geo will 
be explained later. 
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7. This concludes the AMPSolid section of the tutorial. 
 
In these steps, you have generated 3 files that are crucial to the AMPView pre-/post-processor. 
The first one is block1.fe.  The block1.fe file is the finite element data file. It contains the nodes 
and element information of the model. Beside that, you will also see "block1.dat" and 
"block1.geo" files. The ".dat" file is a model definition file that contains the FE control, material 
data, and boundary conditions. It will later be modified when you proceed into the AMPView 
portion of this tutorial to complete the model definition. At this moment, it contains only the 
model dimension data and some version control information. The ".geo" file is an AMPSolid 
internal data file that contains the solid model surface/edge/vertex information for the finite 
element model.  You don't want to change any of these files since they are internal to the 
AMPS operations.  But you will be prompted when they are needed. 
 
Finite Element Modeling Using AMPView/AMPSol 

 
We now proceed to AMPView to start complete the definition of the FEA model for the solver, 
AMPSol, to solve. 
 
1. Select the AMPView icon from the AMPS folder. If you have the AMPSolid still open, 

select File>AMPView FEA Pre/Post and then click Open to accept the default name of 
block1.dat. We don't need AMPSolid anymore, so close the AMPSolid – click Yes to save 
the changes to block1.sat. Now go to step 3. 

2. If AMPSolid wasn't still open, start AMPView, select File>Open, and open the block1.dat 
file. 

3. Within AMPView select IsoView (view icon with XY over Z). Initially, AMPView only 
displays element faces. To make it easier to see the element, turn on the edge and nodes 

displays as well by using the icons as shown. . You should see the picture 
below. 
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4. Setting the Analysis Options  

Open the System property sheet by selecting Model>System/Control. You may have 
notice that under the Model menu, only the System/Control and Material lib options are 
available at this moment. Enter a project title like "3d beam, tetra elements" in the 
"System Control" page and take the default Continuum Stress, 3D, Static problem, and 
Small Strain options. Proceed to the "Solution Controls" page. Take the default Sparse 
Direct Solver, the default time step setting, and the automatic stepping controls. The 
default convergence error norm of 5% is fine. Since this problem will not involve inertia 
effects, ignore the inertia Effect page. The Adaptivity Controls can be ignored as they are 
not used for this tutorial. Enter OK to finish the system setting. 

5. Setting the Material type and Behavior  
In this section, you assign material index 0 to all elements of the model, set the analysis 
behavior of material index 0 to Continuum Stress, and set the material properties of 
material index 0 to match steel. 
We start defining the material behavior by selecting the Model>Define/Material menu. The 
Model>Define/Material menu highlights the elements that match the current Material Index. 
Since there is only one body in this example, by default, the whole body will be highlighted 
to indicate that's the only body selection. 
3.1) Exploring selection options: It a good idea to be familiar with the element 

selection methods. To un-select all elements, click on the icon with just the blue mesh. 
To re-select the body, click the geometric Body Elements selection icon (the top or left 
selection icon and the one with the most red): 

 With the Body Elements selection 
icon active, click on the body to select all the elements in the body. 

3.2) Assigning the Material Index to elements and setting the Behavior for 
the Material:  At this moment, all elements in this body should be highlighted. In the 
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Element Properties page set the Element Material Index to be 0 (the default), and 
select "Continuum Stress" to indicate a solid continuum, and click on the long button 
named "Apply Changes and Update Geometric Selection's material Type". This 
assigns material index 0 to all the selected elements (all elements should be selected). 

3.3) Updating the material stress properties to match steel:  Select the Steel 
material from the material library (bottom right pull-down menu).  Click on the Stress 
tab to verify that the material properties are updated for steel. Once the steel 
properties have been loaded to the stress page they are independent of the steel 
properties in the library and can be changed. Click Apply (upper right) to update the 
properties of material index 0 to reflect the changes.  
 
You have assigned material index 0 to all the elements and set the properties of 
material index 0 for a Continuum Stress analysis of Steel. Click the Close button (X in 
upper right of dialog window) to close the property dialog. 

4. Save the model frequently 
At this moment, we are done with the material definition, so let's save the model information 
by selecting File>Save. It is a good habit to save often. You can always break away at any 
moment, come back by retrieving the save data, and continue from there. 

5. Applying Boundary Conditions and Forces 
We will fix all the nodes on the left end of the beam (left is based on the Iso View) and apply 
a pressure to the right end of the beam to represent a force. 
 
Boundary conditions and forces are applied as condition sets. Each condition set contains 
three parts: 
1) A geometry index identifying the nodes, faces, etc. that receive the condition. 
2) A type index to specifying the type of condition 
3) A time index specifying the time behavior of the condition. 
When we are finished we will have created the following condition sets: 
Combined condition set 0 (fixing the left end) 
 geometry index 0 (the nodes on face at the left end) 
 type index 0 (fix all three coordinates) 
 time index 0 (multiply the condition by 1 for the full time) 
Combined condition set 1 (face pressure in Z direction for right end) 
 geometry index 1 (all element faces on the right end) 
 type index 1 (pressure of 100 in the Z direction) 
 time index 0 (multiply the condition by 1 for the full time) 

6. Fixed End Boundary Conditions for the left end 
We will fix all the nodes on the left end of the beam (left is based on the Iso View). First, 
open the conditions sheet by selecting Model>Conditions. 
6.1) Selecting the left end and assigning geometry index 0 to the nodes on 
that face: 
We want to select the left-hand end nodes first. Let's rotate the beam so that all nine nodes 
at the left-hand end can be seen.  First Click on the (XY over Z) Iso View icon to start with 
the isometric view. The rotate tool is the third tool on the dynamic view toolbar: 

 . Click on the Rotate tool and rotate the model so that the left face is 
visible. Click on the  Face Nodes selection icon. This icon is shown as active on the 

selection toolbar below:  
Click on the left face, and the nodes will be highlighted.  You should see the highlighted 
nodes on the left face as shown.   
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Change the Geometry Condition Index to 0 (the default) by editing the index filed. Now click 
on the [Update/Save] button to save these face nodes as geometry index. The view 
changes so that the selected items are centered in the screen. You can temporarily turn off 
the Display Face and Display Edge icons to verify this. 
 
Update/Save has associated all the nodes in the selected face with geometry index 0. If we 
re-mesh the model, geometry index 0 will still be associated with the nodes connected to 
the left face even though the new nodes will have different coordinates. The 
Elem/Side/Node/Group index for your model does not need to match the dialog below. This 
value depends on how your model was built. 
 



Printed Documentation 

8 

 
 
6.2) Add type condition 0 which restricts the displacement to 0 
Proceed to the Type page. In the Kinematic (LHS) section, select Prescribed Values for 
type condition index 0 (the default).  Click on Update/Save to save this prescribed value 
type as Type index 0. 

 
6.3) Enter (0,0,0) as the Prescribed Value to fix the left end. 
Proceed to the Directional Values page. Set all three directions to 0 to signal a fixed end 
condition (0 will probably be the default value). Click on Update/Save to save the 
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parameters. Since the Directional Values are a part of the Prescribed Values Type condition, 
they share the same index and the index can't be changed on the Directional Value page. 

 
6.4) Add time condition 0 with a constant load factor of 1 
Proceed to the Time page. Specify a start time of 0 and an end time of 1 (default 
conditions) for which the boundary condition will be applied. The value data (entered on 
another page) is scaled by the Load Factor. Make sure the Load Factor is 1 at the Start 
and at the End. The Load Factor used by the processor changes linearly between the Start 
and End times. Intermediate time and Load Factor values can be added to create a more 
complicated piecewise linear function to determine the Load Factor used at a specific time. 
For this model, we set the Start and End Load Factors to 1 for a constant Load Factor of 1. 
Verify that the Time Condition Index is 0 and save the condition using the Update/Save 
button. 
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6.4) Adding Combined Condition Set 0 
Proceed to the Combined/Review Conditions page. So far we have defined the left nodes 
as Geometry index 0, defined a prescribed value of (0, 0, 0) for Type index 0 and defined a 
constant Load Factor of 1 as Time Condition index 0, but we haven't applied anything to the 
model yet. A Combined Condition Set allows us to apply a condition Type (Type and Value) 
to a Geometry (Geometry) with a specified time dependent Load Factor (Time). Verify that 
all the indices on this page are 0 (the ones we've defined) and click Update/Save Set to 
save this association as Condition Set 0. We are done with the fixed end boundary condition. 
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7. Applying a pressure to the right end 
The second boundary condition to specify is a shear load on the right end of the beam.  Click 
on the Iso-View icon to show the right end of the beam. 
7.1) Select the right end and assigning geometry index 1 to the element faces 
on that surface   
Since the shear load is applied on a surface, we have to select the element face for this 
element pressure definition. We will select all the element faces on this right-hand face by 
using the "Solid Element Faces" selection icon. Click on the Solid Element Faces icon as 
show below. 

 
Click on the right face of the beam (the right end is on the right in the Iso View). The 
element faces belong to this face will be highlighted. Select the Geometry page (If the 
Condition sheet in not still visible, Use Model>Conditions to display the property sheet). Set 
the Geometry Condition Index to 1 and click the Add button. The "Add" button is here to 
avoid overwriting a previously defined index. Had we not changed the Geometry index to 1, 
the Add button would have changed the index to 1 (the next available geometry index) and 
then saved the association. The Add button is equivalent to manually changing the index to 
the next free index and clicking the Update/Save button. 

7.2) Add type index 1 which applies a pressure in the global 3(z) direction   
Proceed to the Type page of the Condition Sheet. Under Applied (RHS), select Global 
Pressure/Traction as the type for this condition. We are going to simulate the shear load as a 
global pressure with only component parallel to the face. Click the Add button to add this as 
the next condition. The Type index is incremented to 1 and the type selection is saved. If you 
have trouble with this, you can always overwrite the type index and use the Update/Save 
button. The difference between using this "Global Pressure/Traction" and "Normal 
Pressure/Traction" is that Global Pressure/Traction allows us to enter the global X, Y, Z 
components of the pressure, while in normal pressure you only specify one scalar pressure 
value (the scalar value is entered in direction 1). To apply a shear loading in the global z 
direction, we use Global Pressure/Traction. 
Go to the Directional Values page of the Condition Sheet and enter 100 next to Dir 3 to 
specify a shear loading of 100 in the Z direction. Press the Update/Save button after setting 
the value to save the data. The Type index is still 1 and can only be changed on the Type 
page of the Condition Sheet. Since the global pressure in Dir 1 and Dir 2 is zero, we don't 
have to un-check the Dir 1 and Dir 2 check boxes. 

7.3) Use previously defined time condition 0 
Proceed to the time page. Since the time specification is the same for both boundary 
conditions, we can use the time index 0 here as well. So do nothing on this page. 

7.4) Adding Combined Condition Set 1 
Proceed to the Combine/Review Conditions page. The current indices from the other pages 
have been copied into the appropriate boxes.  Clicking on Add New Set to add a Combined 
Boundary Condition Set Index with an index of 1 and associate it with the Geometry index 1 
(right faces), Type and Value index 1 (Global Shear with 100 in the global Z direction) and a 
Time index of 1 (applied with a Load Factor of 1 from start to end). 
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This concludes our model definition. 
 

8. Save the model again 
Save the model as block1.dat, or just click on File>Save. 
 

9. Reviewing the boundary condition sets 
After loading an old model or before solving a new model, it is useful to quickly review the 
boundary conditions. The Combine/Review Condition page of the Condition Sheet can be used 
to review the conditions. If the Condition Sheet is not already displayed, select 
Model>Condition… to display it. Click on the Combine/Review Conditions tab. Use the pull-
down to select a Combined Boundary Condition Set index. Selecting an index from the pull-
down updates the index numbers on this page and the sets the values on the other pages of 
the Condition Sheet for the specified condition set. Click on the Geometry, Type, Directional 
Value and Time tabs to review the specific conditions associated with this set. When the 
Geometry index changes, AMPView highlights the section of the model associated with the 
new geometry index. . By default, "Display>Zoom to Selection" is on, so the program will 
automatically rotate the view and zoom to the geometry associated with the boundary 
condition. This zoom option can be turned off.  
 
When you are finished reviewing the condition sets, close the Condition Sheet by clicking on 
the close button (the x in the upper right of the dialog). 
 
Using AMPSol to solve the Model 
 

After completing above steps, you can solve your model using AMPSol, the AMPS finite 
element analysis program. Select File>Analyze Model to solve the model. Note that this menu 
selection will not be available if some of the required model definition steps have not been 
completed.  
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The AMPSol program launches and starts to solve the problem. At this moment, if you have 
done the tutorial steps correctly, the solution should be generated within a few seconds 
depending on your computer's processor speed. 
 
When "Process finished." is displayed in the AMPSol window, close the AMPSol window by 
clicking on the close window icon (the x in the upper right corner of the window). 
 
When you selected Analyze>Model, you told AMPSol to solve the finite element model using 
the model definitions in block1.dat, the finite element data in block1.fe, and the related solid 
model file: block1.geo.  When finished, the AMPSOL processor puts the results in the file: 
block1.out.   More details of these files can be found in the AMPView on-line help by pressing 
the F1 help key, using the context sensitive help icon, or selecting Help>Help Topics. 

 
This model is very small so it only takes a short time to solve it. Larger models will take more 
time. AMPSol is designed to take full control of all computer processors while solving the FEA 
model, so other computationally intensive task should be avoided during this time. However, 
you can continue to use AMPView, or even read the partial time/step results if it is available. 
For non-linear problems with multiple time steps, completed partial time/step results can be 
loaded into AMPView and viewed while AMPSol continues to process later time/steps. 
Post Processing with AMPView 
 

Post Processing with AMPView: 
 

1. Since we did not exit AMPView, at the conclusion of the solver run, we can read in the 
AMPSol results by selecting File>Read/Update Results>Read AMPSol Result. 

2. Select Results>contour display>contour type…  and use the pull-down to select dispz. 
Then click OK. A contour plot is displayed on the face. Emphasize its effect by selecting 
the Results>Deformation>Animate option and click OK for the calculated Scaling Factor. 
Using the Animation Control, change the Frames per Cycle (try 100 as the value) and 
click Apply to change the animation speed. Increasing the Frames per Cycle will slow 
down the animation speed and make it smoother. A typical frame is shown in the following: 
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3. Now change the contour type to sig_xx by selecting Results>Contour display>Contour 
type again. To view the stress on the interior edges, turn off the face display (click on the 
Display Face icon and make sure that the Display Edge icon is active). This is one of the 
primary modes for visualizing property variations within a 3D solid. 

 
4. If Animation is still on, turn it off by closing the animation control box or selecting Cancel 

Animation. A deformed view of the model can be created by selecting 
Results>Deformation>Show Displacement. 

 
5. The Results> FE Inquirer>by Node option is used to obtain specific property values at the 

nodes. In the Results>Contour display>Contour type dialog, change the contour type to 
sig_equiv to show the equivalent stress. Select Results>FE Inquirer>by Node and the 
FE Inquirer dialog opens as shown. Use the pull-down to select sig_equiv in the FE Node 
Result Inquirer dialog. Now slide the cursor over a node to obtain the equivalent stress at 
the various nodes. A circle will indicate the selected node. If Display Face is not active, 
turn on Display Face and move the cursor around. With Display Face active, only the 
visible nodes on the surface are selected as you move the mouse. We suggest that you 
change the contour type, and look at different results. One interesting result is the model 
error_norm, which tells you how much error the program predicts based on an energy 
error theory. 
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6. We will now use a cutting plane to visualize the stress contours on the internal element 

faces. Select the middle cutting plane icon, , to turn on a cutting plane that is initially 
in the XY plane. 

7. A cutting plane axis appears at the center of the cutting plane. Move the mouse over the 
vertical cutting plane axis with arrows at the top and bottom. When the mouse is over the 
icon it expands and the left mouse button can be used to drag the cutting plane 
perpendicular to the plane. Moving the mouse over either of the two curved icons with 
arrows at each end also causes them to expand. When the mouse is over them and they 
have expanded, you can drag the mouse with the left mouse button down to rotate the 
cutting plane around the axis. To turn off the cutting plane, click on the cutting plane 
icon again. 
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. 
8. This concludes the post-processing of the AMPSol Results. 
 
Additional Tutorials for Design Analysis 

 
Curious engineers will quickly discover that these results are not as good as they would like.  
This is a simplified tutorial, and is not designed for engineering use.  To improve the accuracy, 
we can use several approaches. Adding more elements (h-refinement), using better elements 
(for the same number of elements hexahedral elements are typically more accurate than 
tetrahedral elements), increase the polynomial order of the elements (p-refinement), or do a 
combination of these. 
 
Here is how you can adjust the initial mesh by going back to the AMPSolid. In this section, we'll 
increase the number of elements and use hexahedral elements. For the same initial Tri Face 
mesh, AutoMesh>Hexa (Solid) from Tri Face generates about 4 times as many elements as 
AutoMesh>Tetra (Solid) from Tri Face. So, even though we still use the same .5 as the 
Approximate Size of Side, more elements will be generated. 
 
The following procedure is similar to Create the Mesh Using AMPSolid section of this tutorial 
except that you'll use AutoMesh> Hexa (Solid) from Tri Faces to create the solid mesh and 
you'll use block1h as the name of the exported mesh. 
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1. Select the AMPSolid icon from the AMPS folder group (or select AMPSolid in AMPS program file 

group) 
2. Input the model by selecting File and select block1.sat from the recently used files list. If 

you haven't created a block1.sat, select block1tut.sat from the "Tutorial" sub-directory and 
open it. Then use File>Save As and save it as block1.sat to match the tutorial file name. 

3. We will generate a tetrahedral volume mesh for the block. The first step is to mesh the 
surface of the block with a triangular mesh (a Tri Face mesh). Here is the detailed steps 

• Click on  to select body selection and then click on the block. The block color 
should change to red to indicate it is selected.  

• Select selecting AutoMesh>Pre-Solid Tri Face Creation …. 
• In the dialog box, Set the Approximate Size of Side to 0.5, and click OK to generate 

the surface triangle mesh. 
4. The second step is to fill the interior with a solid tetrahedron mesh. Select 

AutoMesh>Hexa (Solid) from Tri Faces. You should see a message that the tetra mesh 
cells have been generated and ready for export to the mesh server. Click OK. The new 
mesh should look like the following picture: 

 
5. Export the mesh by selecting File>Export Mesh, and then click OK to accept the default 

options of the Cell Mesh Export Control dialog. Enter block1h as the filename (using a 
different name makes it easier to compare results to the original) and click Save. You 
should see a Finished transfer … message. Click OK to close the message. AMPSolid 
just generates three files. Block1h.fe contains the finite element mesh data. Block1h.dat 
contains the FEA model conditions and block1h.geo contains geometry information. 

6. Since Use current.dat if mesh renamed and no .dat was checked as the default in the 
Export Mesh dialog, Block1.dat was copied to create Block1h.dat as there was no previous 
Block1h.dat. Block1h.dat now contains all the FEA information that we entered using 
AMPView. As long as there is no change in the topology of the model (no new holes or 
surfaces are added) or the type of elements (the elements don't change from solid to shell 
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elements – turning on 2nd order Lagrangian is ok.), we can use the previous .dat file to 
avoid having to re-enter the information in AMPView. 

7. Transfer to AMPView (Using File>AMPView Pre/Post) and use Block1h (or Block1h.dat) 
as the file name and click the Open button. 

8. In AMPView, turn on the element side and node display. Select Model>Conditions. Using 
the Condition Sheet, you can verify that the same conditions are still defined. Notice that 
Geometry Condition index 0 is now associated with all the new nodes on the left end of the 
model and Geometry Condition 1 is associated with all the new faces on the right end of 
the model. You didn't have to re-enter any model information, everything transferred over 
when the Block1.dat file was copied. Close the Condition Sheet by selecting the x in the 
upper right of the dialog. 

Analyze the model by selecting File>Analyze Model and close the AMPSolid window when 
it is finished.  Then retrieve the results. See Post Processing with AMPView for more details. 
You can check the accuracy of the result using your favorite cantilever beam formulation. You 
will find that the results using hexahedral element are closer to the theoretical solution. 
 

 If you are interested in the p-refinement, here is how to do it, 
 

1 Go back to AMPSolid again, and perform the same meshing operation. You can generate 
either a hexa or tetra solid mesh. You can also try to use the AutoMesh>3D Auto Hex 
Meshing …  to generate the solid volume mesh. For 3D Auto Hex Meshing, try a mesh 
using 10x5x5 for the approximate number of cells in the X, Y and Z directions. 

2 Use the File>Export Mesh option to generate a new model, but this time, choose the 
option Generate 2nd order Lagrangian Elements.  Save the new refined mesh under a 
new name such as block1p.fe.   

3 Since Use current.dat if mesh renamed and no .dat was checked as the default in the 
Export Mesh dialog, Block1.dat was copied to create Block1p.dat as there was no previous 
Block1p.dat. This preserves all the FEA information we entered in AMPView for the Block1 
model. 

4 Use AMPView to open the newly generated block1p.dat file. Again, turn on the element 
side and node display. You will find out that all system/define/condition data that you have 
entered are all there.  You don't have to do anything. 

5 Analyze the model by File>Analyze Model. Then retrieve the result when you are done. 
You can check the accuracy of the result using your favorite cantilever beam formulation. 

 
You can of course, combine these two manual h- and p-refinements together, and generate a 
new model. Again, all system control, material data, and boundary conditions are all preserved. 
You just have to re-analyze it.  You can even use the AMPView's adaptive controls on these 
new models, and they will achieve the desired error norm even faster. In AMPView, select 
Model>System/Control to bring up the System Sheet, and then select the Adaptivity Controls 
page for more details. In such case, AMPSol will automatically refine the mesh till the desired 
error_norm is achieved, but may take a longer time to process the model. We will leave that 
exercise to the user. 
 
Finally, to finish this tutorial, let's look at the effect of large deformation and material nonlinear 
plastic model (note: this requires a nonlinear AMPSOL version). 
 
1 Start AMPView and load any of the block1 models. Go to Model>System/Control. On the 

System Controls page select Total Lagrangian Formulation in the Geometry Reference 
Frame Formulation section. Click OK to save the data. 

2 Re-analyze the model and read in the updated results.  You will see the effect of the 
nonlinear geometry.  For small loading, the non-linear results are very close to the linear 
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results. For the Shell Model (later in this tutorial), you'll see a larger difference between the 
linear and non-linear results. 

3 You can increase the load by changing the load factor in the Model>Condition>Time 
page control.  The higher the load, the more iterations the program will have to go through 
to give the results for a large deformation analysis.  Note that if you really load the beam to 
a really large deformation, the automatic time stepping control, as the default setting, may 
kick in and go through several iterations, or try to cut down the load increment as it detect 
the nonlinear effects. 

4 If you are interested in plasticity, AMPSOL has a complete line of metal plasticity with 
either isotropic and/or kinematic hardening behavior.  You can go back to the 
Model/Define session, and choose your favorite plastic model.  For more information about 
these controls, please refer to the AMPView on-line reference help by pressing the F1 help 
key, or use the context sensitive help icon.  After the analysis, look for the yield function 
"yield_func" result, or the accumulated plastic strain "plastic_eps" in the contour display. 
That will reveal the nonlinear material state of stress and strain. 
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Shell Pressure Vessel Modeling Tutorial 

A Shell Modelling Tutorial 

 
The 2nd example in this AMPS tutorial demonstrates solving a 2D/shell model. Many of the 
steps in this shell example are similar to the steps in solving a 2D model. They both use 
triangular and/or quadrilateral elements. True 2D models must be created in the XY plane. 
 
The pressure vessel model used for this tutorial is a pressured storage tank constructed from 
two cylinders. The tank body is constructed using a cylinder of 5' by 10' (60 by 120 inches) 
lying horizontally.  In the center region, a vertical cylinder of 3' by 5' is used to construct the 
access cap.  The pressure vessel has been created for you and is in the file "pvessel.sat".   
You will learn how to define the FE controls, material, boundary conditions, and examine the 
results from this tutorial. 

 
Creating Shell Meshes Using AMPSolid 
1. Select the AMPSolid icon from the AMPS folder group. 
2. Input the model by selecting File>open and entering pvessel.sat from the "Tutorial" sub-

directory. Click on the Iso View icon  to change to the isometric view.   

3. To select the pressure vessel so it can be meshed, click on the body selector icon . 
Then click on one of the cylinders that form the pressure vessel. 

4. To generate a mesh on the selected body, select AutoMesh>Surface Meshing…. 
Change Approximate size of a side to 10 for a coarse mesh. Change Mesh Shape 
Control to Quadrilaterals Only (the triangle elements are too stiff for pressure effects) and 
use the default values for the rest of the parameters. Click OK and the new shell mesh 
should be displayed fairly quickly.  If you made a mistake, just use AutoMesh>Reset Mesh, 
then repeat this step to create a shell mesh. 

5. Examine the resulting mesh by using the Rotate View command: .  Turn face shading  
off so you can see the mesh better. Face shading is the left icon on the shading icon 

toolbar: . 
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6. Save the FlexMesh data as "pvessel.flx" by selecting "File>Save FlexMesh as" menu.  If 
you don't save it, you will not be able to recall the mesh later. Use the default name of 
pvessel.flx and click Save in the Save As dialog. 

7. Now export the mesh as "pvessel.fe". Start by selecting "File>Export Mesh". Make sure 
the "Generate 3-D Shell Elements" box is checked and click OK to export the mesh. The 
default filename of pvessel.fe is good, so just click Save on the Save As dialog. Click OK 
to close the Finished transfer message. 

8. This concludes the AMPSolid session. 
 
If you have trouble doing these steps, you may want to go back to the AMPSolid tutorial to 
familiar yourself with some of the solid modeling operations.  And if you really got lost and still 
want to continue with this tutorial, load "pvsolved.sat" from the "Tutorial" subdirectory and save 
it as pvessel.sat. Then repeat the mesh generation steps (steps 5-8 in this section). 
Finite Element Modeling Using AMPView/AMPSol 

 
We now proceed to AMPView to start complete the definition of the FEA model for the solver, 
AMPSol, to solve. 
 
6. Select the AMPView icon from the AMPS folder. If you have the AMPSolid still open, 

select File>AMPView FEA Pre/Post and then click Open to accept the default name of 
block1.dat. We don't need AMPSolid anymore, so close the AMPSolid – click Yes to save 
the changes to block1.sat. Now go to step 3. 

7. If AMPSolid wasn't still open, start AMPView, select File>Open, and open the block1.dat 
file. 

8. Within AMPView select IsoView (view icon with XY over Z). Initially, AMPView only 
displays element faces. To make it easier to see the element, turn on the edge and nodes 

displays as well by using the icons as shown. . You should see the picture 
below. 
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9. Setting the Analysis Options  

Open the System property sheet by selecting Model>System/Control. You may have 
notice that under the Model menu, only the System/Control and Material lib options are 
available at this moment. Enter a project title like "3d beam, tetra elements" in the 
"System Control" page and take the default Continuum Stress, 3D, Static problem, and 
Small Strain options. Proceed to the "Solution Controls" page. Take the default Sparse 
Direct Solver, the default time step setting, and the automatic stepping controls. The 
default convergence error norm of 5% is fine. Since this problem will not involve inertia 
effects, ignore the inertia Effect page. The Adaptivity Controls can be ignored as they are 
not used for this tutorial. Enter OK to finish the system setting. 

10. Setting the Material type and Behavior  
In this section, you assign material index 0 to all elements of the model, set the analysis 
behavior of material index 0 to Continuum Stress, and set the material properties of 
material index 0 to match steel. 
We start defining the material behavior by selecting the Model>Define/Material menu. The 
Model>Define/Material menu highlights the elements that match the current Material Index. 
Since there is only one body in this example, by default, the whole body will be highlighted 
to indicate that's the only body selection. 
9.1) Exploring selection options: It a good idea to be familiar with the element 

selection methods. To un-select all elements, click on the icon with just the blue mesh. 
To re-select the body, click the geometric Body Elements selection icon (the top or left 
selection icon and the one with the most red): 

 With the Body Elements selection 
icon active, click on the body to select all the elements in the body. 

9.2) Assigning the Material Index to elements and setting the Behavior for 
the Material:  At this moment, all elements in this body should be highlighted. In the 
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Element Properties page set the Element Material Index to be 0 (the default), and 
select "Continuum Stress" to indicate a solid continuum, and click on the long button 
named "Apply Changes and Update Geometric Selection's material Type". This 
assigns material index 0 to all the selected elements (all elements should be selected). 

9.3) Updating the material stress properties to match steel:  Select the Steel 
material from the material library (bottom right pull-down menu).  Click on the Stress 
tab to verify that the material properties are updated for steel. Once the steel 
properties have been loaded to the stress page they are independent of the steel 
properties in the library and can be changed. Click Apply (upper right) to update the 
properties of material index 0 to reflect the changes.  
 
You have assigned material index 0 to all the elements and set the properties of 
material index 0 for a Continuum Stress analysis of Steel. Click the Close button (X in 
upper right of dialog window) to close the property dialog. 

10. Save the model frequently 
At this moment, we are done with the material definition, so let's save the model information 
by selecting File>Save. It is a good habit to save often. You can always break away at any 
moment, come back by retrieving the save data, and continue from there. 

11. Applying Boundary Conditions and Forces 
We will fix all the nodes on the left end of the beam (left is based on the Iso View) and apply 
a pressure to the right end of the beam to represent a force. 
 
Boundary conditions and forces are applied as condition sets. Each condition set contains 
three parts: 
4) A geometry index identifying the nodes, faces, etc. that receive the condition. 
5) A type index to specifying the type of condition 
6) A time index specifying the time behavior of the condition. 
When we are finished we will have created the following condition sets: 
Combined condition set 0 (fixing the left end) 
 geometry index 0 (the nodes on face at the left end) 
 type index 0 (fix all three coordinates) 
 time index 0 (multiply the condition by 1 for the full time) 
Combined condition set 1 (face pressure in Z direction for right end) 
 geometry index 1 (all element faces on the right end) 
 type index 1 (pressure of 100 in the Z direction) 
 time index 0 (multiply the condition by 1 for the full time) 

12. Fixed End Boundary Conditions for the left end 
We will fix all the nodes on the left end of the beam (left is based on the Iso View). First, 
open the conditions sheet by selecting Model>Conditions. 
6.1) Selecting the left end and assigning geometry index 0 to the nodes on 
that face: 
We want to select the left-hand end nodes first. Let's rotate the beam so that all nine nodes 
at the left-hand end can be seen.  First Click on the (XY over Z) Iso View icon to start with 
the isometric view. The rotate tool is the third tool on the dynamic view toolbar: 

 . Click on the Rotate tool and rotate the model so that the left face is 
visible. Click on the  Face Nodes selection icon. This icon is shown as active on the 

selection toolbar below:  
Click on the left face, and the nodes will be highlighted.  You should see the highlighted 
nodes on the left face as shown.   
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Change the Geometry Condition Index to 0 (the default) by editing the index filed. Now click 
on the [Update/Save] button to save these face nodes as geometry index. The view 
changes so that the selected items are centered in the screen. You can temporarily turn off 
the Display Face and Display Edge icons to verify this. 
 
Update/Save has associated all the nodes in the selected face with geometry index 0. If we 
re-mesh the model, geometry index 0 will still be associated with the nodes connected to 
the left face even though the new nodes will have different coordinates. The 
Elem/Side/Node/Group index for your model does not need to match the dialog below. This 
value depends on how your model was built. 
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6.2) Add type condition 0 which restricts the displacement to 0 
Proceed to the Type page. In the Kinematic (LHS) section, select Prescribed Values for 
type condition index 0 (the default).  Click on Update/Save to save this prescribed value 
type as Type index 0. 

 
6.3) Enter (0,0,0) as the Prescribed Value to fix the left end. 
Proceed to the Directional Values page. Set all three directions to 0 to signal a fixed end 
condition (0 will probably be the default value). Click on Update/Save to save the 
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parameters. Since the Directional Values are a part of the Prescribed Values Type condition, 
they share the same index and the index can't be changed on the Directional Value page. 

 
6.4) Add time condition 0 with a constant load factor of 1 
Proceed to the Time page. Specify a start time of 0 and an end time of 1 (default 
conditions) for which the boundary condition will be applied. The value data (entered on 
another page) is scaled by the Load Factor. Make sure the Load Factor is 1 at the Start 
and at the End. The Load Factor used by the processor changes linearly between the Start 
and End times. Intermediate time and Load Factor values can be added to create a more 
complicated piecewise linear function to determine the Load Factor used at a specific time. 
For this model, we set the Start and End Load Factors to 1 for a constant Load Factor of 1. 
Verify that the Time Condition Index is 0 and save the condition using the Update/Save 
button. 
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6.4) Adding Combined Condition Set 0 
Proceed to the Combined/Review Conditions page. So far we have defined the left nodes 
as Geometry index 0, defined a prescribed value of (0, 0, 0) for Type index 0 and defined a 
constant Load Factor of 1 as Time Condition index 0, but we haven't applied anything to the 
model yet. A Combined Condition Set allows us to apply a condition Type (Type and Value) 
to a Geometry (Geometry) with a specified time dependent Load Factor (Time). Verify that 
all the indices on this page are 0 (the ones we've defined) and click Update/Save Set to 
save this association as Condition Set 0. We are done with the fixed end boundary condition. 
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13. Applying a pressure to the right end 
The second boundary condition to specify is a shear load on the right end of the beam.  Click 
on the Iso-View icon to show the right end of the beam. 
7.1) Select the right end and assigning geometry index 1 to the element faces 
on that surface   
Since the shear load is applied on a surface, we have to select the element face for this 
element pressure definition. We will select all the element faces on this right-hand face by 
using the "Solid Element Faces" selection icon. Click on the Solid Element Faces icon as 
show below. 

 
Click on the right face of the beam (the right end is on the right in the Iso View). The 
element faces belong to this face will be highlighted. Select the Geometry page (If the 
Condition sheet in not still visible, Use Model>Conditions to display the property sheet). Set 
the Geometry Condition Index to 1 and click the Add button. The "Add" button is here to 
avoid overwriting a previously defined index. Had we not changed the Geometry index to 1, 
the Add button would have changed the index to 1 (the next available geometry index) and 
then saved the association. The Add button is equivalent to manually changing the index to 
the next free index and clicking the Update/Save button. 

7.2) Add type index 1 which applies a pressure in the global 3(z) direction   
Proceed to the Type page of the Condition Sheet. Under Applied (RHS), select Global 
Pressure/Traction as the type for this condition. We are going to simulate the shear load as a 
global pressure with only component parallel to the face. Click the Add button to add this as 
the next condition. The Type index is incremented to 1 and the type selection is saved. If you 
have trouble with this, you can always overwrite the type index and use the Update/Save 
button. The difference between using this "Global Pressure/Traction" and "Normal 
Pressure/Traction" is that Global Pressure/Traction allows us to enter the global X, Y, Z 
components of the pressure, while in normal pressure you only specify one scalar pressure 
value (the scalar value is entered in direction 1). To apply a shear loading in the global z 
direction, we use Global Pressure/Traction. 
Go to the Directional Values page of the Condition Sheet and enter 100 next to Dir 3 to 
specify a shear loading of 100 in the Z direction. Press the Update/Save button after setting 
the value to save the data. The Type index is still 1 and can only be changed on the Type 
page of the Condition Sheet. Since the global pressure in Dir 1 and Dir 2 is zero, we don't 
have to un-check the Dir 1 and Dir 2 check boxes. 

7.3) Use previously defined time condition 0 
Proceed to the time page. Since the time specification is the same for both boundary 
conditions, we can use the time index 0 here as well. So do nothing on this page. 

7.4) Adding Combined Condition Set 1 
Proceed to the Combine/Review Conditions page. The current indices from the other pages 
have been copied into the appropriate boxes.  Clicking on Add New Set to add a Combined 
Boundary Condition Set Index with an index of 1 and associate it with the Geometry index 1 
(right faces), Type and Value index 1 (Global Shear with 100 in the global Z direction) and a 
Time index of 1 (applied with a Load Factor of 1 from start to end). 
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This concludes our model definition. 
 

14. Save the model again 
Save the model as block1.dat, or just click on File>Save. 
 

15. Reviewing the boundary condition sets 
After loading an old model or before solving a new model, it is useful to quickly review the 
boundary conditions. The Combine/Review Condition page of the Condition Sheet can be used 
to review the conditions. If the Condition Sheet is not already displayed, select 
Model>Condition… to display it. Click on the Combine/Review Conditions tab. Use the pull-
down to select a Combined Boundary Condition Set index. Selecting an index from the pull-
down updates the index numbers on this page and the sets the values on the other pages of 
the Condition Sheet for the specified condition set. Click on the Geometry, Type, Directional 
Value and Time tabs to review the specific conditions associated with this set. When the 
Geometry index changes, AMPView highlights the section of the model associated with the 
new geometry index. . By default, "Display>Zoom to Selection" is on, so the program will 
automatically rotate the view and zoom to the geometry associated with the boundary 
condition. This zoom option can be turned off.  
 
When you are finished reviewing the condition sets, close the Condition Sheet by clicking on 
the close button (the x in the upper right of the dialog). 
 
Post Processing Shell Model 
 
Post Processing with AMPView: 
 

1. Since we did not exit AMPView, at the conclusion of the solver run, we can read in the 
AMPSol results by selecting File>Read /Update Results>Read AMPSol Result. 

2. We now proceed to the AMPSol result options and examine the overall results of our 
analysis. 
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3. Select the Results>Contour Display>Contour Type … menu item to display the Contour 
Display Control dialog and select sig_equiv from the Available Contour types pull-down. 
Then click OK A contour plot is displayed on the face. Emphasize its effect by selecting 
the Results>Deformation>Animate option. In the Animation Control dialog, increase the 
Frames per Cycle (try 100) and click Apply. Increasing the Frames per Cycle slows down 
the animation and makes it smoother. A typical frame is shown in the following. 

 
4. The mesh for this analysis is really not fine enough to judge the behavior of the tank under 

the internal 100 psi loading, but it does point out interesting behavior. Note that for shell 
models, this contour display is for the mid-plane result. To see the behavior of the shell's 
front or the back surface, use the Results>ContourDisplay>Shell/Element Contour option 
to see the shell element's surface result.  The front and back surfaces have somewhat 
different results due to the bending behavior. The mid-plane results are basically from the 
membrane behavior, but they are tightly coupled. Let your engineering mind flow, but let's 
move on with this tutorial. When the Results>Contour Display>Contour Type …menu 
command is used to contour results for shell elements, the mid-plane value is used. When 
Results>Contour Display>Shell Element Contour is used to contour results for shell 
elements, the user can specify Front Side or Back Side. 

 
5. Next, we will use the Results>FE Inquirer>by Element to obtain specific property values at 

the element's top and bottom surface. Change the contour type to sig_equiv, the 
equivalent stress display. Select the Results>FE Inquirer>by Element menu item. The 
FE Element Result Inquirer window will open as shown. Now slide the cursor over a 
shell element to obtain the equivalent stress on the element. The element's connectivity 
data will be displayed too.  
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6. This concludes the post-processing of the AMPSol Results for the shell model. 
 
We strongly suggest that you go back to this model in AMPSolid, and change the mesh to a 
slightly finer one, or choose the 2nd order Lagrangian elements.  Use a different name (like 
pvessel2) when you Export the mesh if you want to compare results to the initial analysis. You 
will notice that the model data remain valid even after you change the mesh in the AMPSolid.  
You can then resolve the model using the new mesh, and use your engineering judgement to 
examine the result. 

 
Here are some comments on our current shell elements. SHELL3 refers to a shell element with 
three nodes, SHELL6 is a shell element exported with Generate 2nd order Lagrangian 
Elements checked when using File>Export Mesh from AMPSolid. The SHELL6 element has an 
extra node along each edge. SHELL4 elements are enhanced quad elements. SHELL9 
elements are quad elements exported with Generate 2nd order Lagrangian Elements checked 
when using File>Export Mesh from AMPSolid. The SHELL9 elements have an extra node 
along each edge and one at the center. The dispx (x displacement) contour shows the most 
difference between elements. 
 
SHELL3 (tri) 
These are very stiff (dispx too small), but converge to the solution as more elements are used. 
SHELL4 (quad) 
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These elements are fast and accurate at low to medium resolution but using more (smaller) 
elements will not necessarily improve the accuracy. 
SHELL6 (tri + 2nd order Lagrangian) 
These are better than SHELL3 but still too stiff. They converge to the solution as more 
elements are used. 
SHELL9 (quad + 2nd order Lagrangian) 
Generally consistent with SHELL4, results improve as the mesh is refined. These are the most 
robust elements but because each element has 9 nodes, solutions times are longer than for 
SHELL9 than the other elements. 
 
Non-Linear analysis of the Pressure Vessel 
If you use non-linear analysis for this model, the results are different. 
 
To try non-linear analysis, generate a Quad or Mixed mesh and export the mesh with NO 
CHECK on Use 2nd order Lagrangian elements. Export the mesh and start AMPView. 
 
In AMPView, Go to Model>System/Control. On the System Controls page select Total 
Lagrangian Formulation in the Geometry Reference Frame Formulation section. Click OK to 
save the data. If the model doesn't converge with a step size of 1.0, use a smaller initial 
Time/Step Increment. Go to Model>System/Control. On the Solution Controls page, set 
Initial Time/Step Increment to .2 and solve the model again. 
 
After solving the model, look at the dispx contour. There is a difference between the linear 
results and the non-linear results. The center of the end caps deflect more when linear 
analysis is used for this problem because linear analysis only considers bending of the 
elements. When the physical end caps bend out, they also stretch and this stretching applies a 
force and reduces the deflection necessary for the middle of the end caps. The non-linear 
analysis with Total Lagrangian includes this stretching force and provides more realistic results. 
 
Using spherical end caps 
Most pressure vessels use spherical end caps. This significantly reduces the maximum stress 
and deflection. The pvsphere model in the "Tutorial" sub-directory was created from the 
CylSphere.sat model from Step 4 of the AMPSolid tutorial. The .dat file from pvessel was used. 
Because of the geometry change, the Model>Conditions index 0 geometry needed to be 
changed back to represent the edge of the original large cylinder but all other specifications 
were kept. You can load the pvsphere.dat model into AMPView to experiment with a more 
realistic design. If you want to change the mesh, you'll need to load pvsphere.sat into 
AMPSolid. 
 
 
This concludes the shell pressure model tutorial. 
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Suggestions and Comments 

Suggestions and Comments 
 

We now conclude the tutorial of  AMPSOL finite element modeling using the AMPView pre-
/post-processor.  We hope that after this tutorial, you are able to use AMPS in your design 
analysis. We also look forward to hearing from you and receiving any comments or 
recommendations. If you need assistance or have any comments, please contact 
support@ampstech.com. 
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